Password Reset Issue

Incident Report for Reward Gateway

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 20, 2026 - 15:44 UTC

Identified

We've identified the root cause of the password reset issue and are actively working on a fix. We appreciate your patience and will post another update soon.
Posted Aug 20, 2026 - 10:40 UTC

Investigating

We're aware that some users attempting to reset their password are unable to complete the process. Our team is investigating and working to resolve this with high priority. We'll post updates here as we learn more.
Posted Aug 20, 2026 - 08:58 UTC